Links on Teams & Outlook Open in Microsoft Edge Instead of Computer's Default Browser


Issue

In Windows, even though I have my default browser set (such as: Google Chrome or Firefox), whenever I open a link in Microsoft Outlook or Microsoft Teams, it opens in Microsoft Edge instead of the browser I have set as default (such as Google Chrome or Firefox).

 

 

 

Environment

Occurs in Microsoft Outlook and "New" Teams installed on computers running Microsoft Windows.

Cause

In newer versions of Microsoft Outlook and Microsoft Teams (specifically "New" Teams), the default is set so hyperlinks open in Microsoft Edge as opposed to the computer's default web browser. There is a setting that needs to be changed so hyperlinks open in the computer's default web browser instead of Microsoft Edge.

Resolution

 

Before you Begin

 

Verify that you have your default web browser set in Windows settings. Click here to go to the Default Apps settings. The full path is Settings > Apps > Default Apps.

 

On Windows 11 and newer, you will need to go to the application's properties page (in this example, Google Chrome), and ensure the app is set as default. Click the Set Default button. You will see a check mark indicating it is set as default.

 

You should also verify that your HTTP and HTTPS links are set to open in your default browser as well. Once your browser has been verified, you will need to change the settings in Outlook and Teams.

 

More information on changing your default browser can be found here: Setting your Default Web Browser on Windows and Mac

Changing your Settings in Outlook

1) In Outlook, go to File > Options.

2) In the options window, go to Advanced. Scroll down to File and browser preferences.

3) In the drop-down next to Open hyper links from Outlook in: , select Default Browser. Click OK to save changes.

 

Changing Settings in Teams

 

1) Click on the Settings and more button (indicated as an ellipsis), then click Settings.

2) On the left pane, click Files and Links.

3) Scroll down to the Links open preference section. In the drop-down, select Default Browser. Click OK to save changes.

 

Your links should open in your computer's default web browser.

 

More information on Microsoft Outlook and Microsoft Teams can be found in the following Knowledge Articles:

 

We hope you have found this information helpful!

Please visit the Wesleyan ITS Knowledgebase to locate additional self-help instruction.

To request further assistance please: